Services – Less critical – Access bypass – SA-CONTRIB-2019-043

Project: ServicesVersion: 7.x-3.x-devDate: 2019-April-03Security risk: Less critical 9∕25 AC:Complex/A:User/CI:Some/II:None/E:Theoretical/TD:DefaultVulnerability: Access bypassDescription: This module provides a standardized solution for building API’s so that external clients can communicate with Drupal.
The Services module has an access bypass vulnerability in its “attach_file” resource that allows users who have access to create or update nodes that include file fields to arbitrarily reference files they do not have access to, which can expose private files.
This vulnerability is mitigated by the fact that an attacker must have a role with permission to create or edit a node.Solution: Install the latest version:
If you use the Services module for Drupal 7.x, upgrade to Services 7.x-3.24
Also see the Services project page.Reported By: Samuel Mortenson of the Drupal Security Team
Fixed By: Tyler Frankenstein
Coordinated By: Samuel Mortenson of the Drupal Security Team
Greg Knaddison of the Drupal Security Team


Original URL: https://www.drupal.org/sa-contrib-2019-043

Original article

Proudly powered by WordPress | Theme: Baskerville 2 by Anders Noren.

Up ↑

%d bloggers like this: