Node Embed – Denial of Service – Less critical – SA-CONTRIB-2016-034

Advisory ID: DRUPAL-SA-CONTRIB-2016-034
Project: Node Embed (third-party module)
Version: 7.x
Date: 2016-June-08
Security risk: 5/25 ( Less Critical) AC:Complex/A:User/CI:None/II:None/E:Theoretical/TD:Uncommon
Vulnerability: Denial of Service
Description
This module enables you to embed the contents of one node in the body field of another.
The module doesn’t sufficiently protect against a node being embedded in itself, or a loop being created of one node being embedded in another which is then itself embedded in the first node.
This vulnerability is mitigated by the fact that an attacker must have a role with the permission to create content which allows other content to be embedded.

CVE identifier(s) issued
A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.
Versions affected
All Node Embed 7.x-1.x versions.
Drupal core is not affected. If you do not use the contributed Node Embed module, there is nothing you need to do.
Solution
If you use the Node Embed module for Drupal 7.x you should uninstall it.
Also see


Original URL: https://www.drupal.org/node/2744917

Original article

Comments are closed.

Proudly powered by WordPress | Theme: Baskerville 2 by Anders Noren.

Up ↑

%d bloggers like this: